I'm available for contracting work in August. Lets get in touch.

micro.blog-entry

So it turns out that iOS users don’t update their phones with most recent iOS version right away. Vorto 1.0.3 with lower iOS requirements is on its way….

Leave a Reply

Your email address will not be published. Required fields are marked *